Waves Confirm Mac OS X 10.10 Yosemite Compatibility

10-23-2014 05:48 PM

Waves have announced that Waves Native plug-ins and WLC are now OS X 10.10 Yosemite Compatibile.
Their full statement reads:
Dear Valued Waves User,

We are pleased to announce that all Waves Native plugins V9 as well as the Waves License Center are now fully compatible with Mac OS X 10.10 Yosemite.
Click here to download the updated installer.

Please note: SoundGrid plugins and software applications are not yet supported by Mac OS X 10.10 Yosemite. We are working to resolve this compatibility issue as soon as possible.

If further assistance is required, you are more than welcome to contact our tech support team.

Best regards,
The Waves Team
For more information visit Waves web site