Does Pro Tools Run Better On Dedicated Machines? We Tested It To Find Out.

05-04-2014 09:43 AM

If you’ve had trouble with Pro Tools then there may have been some point when you have been directed to a number of ways to try and solve it. Avid have some helpful trouble shooting guides as well as system optimisation.
We have an entire section on this blog to help you get the best from your Pro Tools system, kindly sponsored by dedicated Pro Tools computer builders, Pro Tools PC.
Some suggest that turning off network cards, Wi-fi, Bluetooth, Disk Search tools like Spotlight, and background apps that do things like monitoring hard drives can make a difference.
We often suggest that you do a clean build and also use an OS that may not be the most up-to-date snazzy latest version, but is proven to work better.
Perhaps you’ve taken all of these things with a pinch of salt and thought that your crashes or slow performance are down to software bugs and not the way your Pro Tools machine is set-up. Or perhaps you are one of those people who thinks, ‘why should I have to set my machine up around Pro Tools, surely it should just work?’ Well in theory that may be a fair thing to think, but car manufacturers suggest oil and fuel types for better performance, or the best tyre pressure to get optimum mileage and efficiency, of course we can choose to ignore the advice, but it may mean we end up with performance that is far worse than it could be.
The Pro Tools Challenge

I decided to see what would happen if I installed two identical Crucial M500 SSD drives in my Mac Pro and on one drive ran the Mac as I would any other computer I own, with all the Apps I would normally have installed on my computer like Office, Photoshop etc as well as plenty of handy little Apps and with every process running like it does normally. I am also unique in the fact that my machine has beta versions of plug-ins as well as demos and, as a reviewer, a lot more plug-ins than the average bear. The install of Pro Tools is 11.1.3 and not a clean install, simply an upgrade from previous versions. This Mac is running OS X 10.8.5 Mountain Lion
On the second identical drive, a Crucial M500 SSD, I formatted it from the box, installed OS X 10.8.3 Mountain Lion and then a clean install of Pro Tools 11.1.3. I then only installed the plug-ins I really use, so no betas, no demos, no stuff I use once in a blue moon. You can see the Applications installed in the image below, yep it’s pretty sparse. The suff in red highlight is the stuff that Apple install and won’t let me remove, it seems that Photo Booth is an essential system application! ;)

I won’t go into my issues with Mavericks in this article as that would just muddy the water, suffice to say, I’m not a fan, so this test is using Mountain Lion.
This is an identical machine, which has two start-up drives so I can dual boot, one for day-to-day work the other as my studio Pro Tools machine.
Pro Tools Start Up Speed

You may or may not be aware, but every time Pro Tools starts up it scans you plug-in folder and then loads the plug-ins it finds there. So that means every plug-in you own, demo plug-ins, beta plug-ins, the good the bad and the ugly. The first thing this does is impact on start-up time, if you have a beta or incompatible plug-in then it may even crash before it gets started.
Here’s a video showing my day-to-day Mac install booting Pro Tools and my dedicated Mac install booting up Pro Tools. REMEMBER IT IS THE SAME MACHINE.

As you can see the additional plug-ins that I don’t need are adding around 12 seconds to the start-up process, that’s if it boots without crashing.
Pro Tools Session Performance Compared

The next test was to see what would happen if I loaded the same session into the two different Pro Tools installs, you can see from the graphic below.
On the left is the regular build and on the right the dedicated Pro Tools build.

So the same session and one runs at 19% and the other 7%, the same machine, just different settings. Furthermore at a 256 sample buffer size the regular install would crash and throw up error messages, whereas the dedicated build did not blink. You can see on the left the Total CPU meter is doing the familiar jump up and down, the dedicated install is rock solid at 7%.
Furthermore the dedicated Pro Tools install had a snappier performance and felt less sluggish. REMEMBER IT IS THE SAME MACHINE.
Does Pro Tools Run Better On Dedicated Machines?

From these basic tests I have found that by installing Pro Tools on a dedicated drive I get the following benefits;

  • Faster start up time
  • Better session performance
  • Less plug-ins to trawl through when selecting a plug-in
  • Fewer crashes
  • Snappier performance all round
  • No distractions from Mail, Notifications and Social Media Apps

You may think that to buy a machine just to run Pro Tools is just too expensive, however by buying a second hard drive you get both. My Crucial M500 960gb SSD drive cost me just over £300 and was installed in around 5 minutes.
Now I have the best of both worlds, effectively two 12 core Mac Pros, one for general work and for testing out demos and betas and the other as a rock solid Pro Tools studio machine for around £300 - it’s a no-brainer. You would be amazed how many plug-ins are left if you get brutal and keep only the ones you use all the time, you can always keep the ones you used sometimes in the Unused plug-ins folder and then drop them back into the plug-ins folder when you need them. I suppose with the Unused plug-ins folder the clue is in the name ;).
All my sessions, samples and other content is on separate drives so there’s no issue about having to find another session, sample or library on another machine.
So if you are having constant crashes and performance issues with your Pro Tools system, it could be a bug in Pro Tools, but it could be your machine. It’s important to find out which one it is because if thousands of people have got Avid chasing non-existent bugs then that’s time they could be spending fixing the long list of really important ones.
PS: Avid if you are reading this Step Input is still broken not even a clean build could fix that bug.